8.4. Задача на самостоятельное решение - Учебное пособие рпк “Политехник” Волгоград
.RU

8.4. Задача на самостоятельное решение - Учебное пособие рпк “Политехник” Волгоград


^ 8.4. Задача на самостоятельное решение
Имеются данные о продажах определенных типов автомобилей, производимых разными странами, за первое полугодие по месяцам.

Требуется:
8.5. Самоконтроль
В результате изучения главы 8 Вы должны освоить:

  1. Принципы и методы обработки информации (сортировку данных, поиск данных, вычисление среднего значения, максимального значения, минимального значения, вычисление процентов, выделение категорий данных);

  2. Работу с функциями Excel позволяющими осуществлять обработку информации;

  3. Работу с массивами в Excel;

  4. Построение графиков отображающих информацию в наиболее наглядном виде;

  5. Создание простейших программ по выводу статистической информации.

Вы должны знать:

  1. Процедуры обработки информации (подсчет среднего балла, нахождение минимального и максимального значений, сортировку данных, вычисление процентов и условного форматирования, выделение категорий данных, поиск данных);

  2. Процедуру создания графиков, их типы и назначение;

  3. Процесс создания программ, отображающих информацию, используемые интерфейсные объекты, методы, свойства, события.
^ 8.5.1. Контрольные вопросы

  1. Что такое примечание?

  2. Как создать Работа с примечаниями?

  3. Как изменить Работа с примечаниями?

  4. Как удалить Работа с примечаниями?

  5. Можно ли использовать функции форматирования (жирный шрифт, размер, цвет) по отношению к Работа с примечаниями?

  6. Как Округление число с помощью функции Excel?

  7. Как установить Вычисление процентных отношений ячеек в Excel?

  8. Как вычислить среднего балла с помощью функции Excel?

  9. Можно ли вычислить среднее значение, не используя функцию СРЗНАЧ?

  10. Что находит функция СЧЁТЕСЛИ? Приведите пример применения функции.

  11. Как подсчитать ЧИСЛСТОЛБ в диапазоне?

  12. Как выделяют категории студента? Опишите процесс выделения необходимых данных.

  13. Приведите несколько примеров применения функции Примеры?

  14. Может ли функция Замечание быть вложенной в другую функцию?

  15. Как определить стипендии студента?

  16. Что такое Абсолютной ссылкой ?

  17. Что такое Относительными ссылками ?

  18. Что такое Диапазон?

  19. Что вычисляет функция СУММЕСЛИ? Приведите пример.

  20. Как Вычисление процентных отношений?

  21. Всегда ли Замечание отдельных категорий будет равна 100%? Как можно избежать этого?

  22. Может ли Замечание при округлении начальных значений быть больше 100%.

  23. Как найти определения максимального балла в диапазоне ячеек?

  24. Что вычисляет функция ПОИСКПОЗ?

  25. Какие типы сопоставления есть у функции ПОИСКПОЗ?

  26. Что выполняет функция ТЕКСТ?

  27. Объясните, как получить Определение же названия предмета с максимальным средним баллом.

  28. Как выполнить условные форматы ?

  29. Что такое условные форматы ?

  30. Чем Шаг 3. в условном форматировании: «по значению» от критерия «по формуле»?

  31. Как выделить категорию двоечников с помощью условного форматирования?

  32. Как выделить категорию хорошистов с помощью условного форматирования?

  33. Какие двух классов Вы знаете?

  34. Какие типы стандартных диаграмм Вам известны?

  35. Перечислите несколько Нестандартные диаграммы (не менее пяти).

  36. Опишите шаги мастера по созданию диаграмм.

  37. Опишите назначение элемента управления ««Кнопка» и его свойства.

  38. Опишите назначение объекта класса ««Рамка» и его свойства.

  39. Опишите назначение объекта класса ««Счетчик» и его свойства.

  40. Опишите назначение объекта класса UserForm и его свойства.

  41. Что выполняет метод Show? Для чего он используется в программе?

  42. Что выполняет метод AddItem? Для чего он используется в программе?

  43. Когда происходит событие ««Click»? У какого объекта оно может возникать? Как событие обрабатывается в программе?

  44. Когда происходит событие ««Initialize»? У какого объекта оно может возникать? Как событие обрабатывается в программе?

  45. Что вычисляет функция Format? Для чего она применяется в программе?

  46. Что вычисляет функция Str? Для чего она применяется в программе?

  47. Что вычисляет функция Trim? Для чего она применяется в программе?

  48. Расскажите алгоритм подсчета числа двоек.

  49. Расскажите алгоритм подсчета числа троечников.

  50. Расскажите алгоритм подсчета числа хорошистов.

  51. Расскажите алгоритм подсчета числа пятерок.

  52. Расскажите алгоритм подсчета числа двоек.

  53. Расскажите алгоритм подсчета числа троек.

  54. Расскажите алгоритм подсчета числа четверок.

  55. Расскажите алгоритм подсчета числа пятерок.

  56. Расскажите алгоритм список, получающих стипендию.

  57. Как произвести сортировку данных?

  58. Что такое порядком сортировки ? Какие Вам известны стандартные порядки сортировки.

  59. Что такое пользовательский порядок сортировки ? Как его создать?

  60. Для чего используется пользовательский порядок сортировки ?

  61. Что определяет понятие массива в Excel?

  62. Что такое формула массива? Для чего она используется? Приведите пример.

  63. Что вычисляет функция НАИБОЛЬШИЙ? Какие у нее есть параметры? Приведите пример.

  64. Что вычисляет функция НАИБОЛЬШИЙ? Какие у нее есть параметры? Приведите пример.

  65. Расскажите процедуру автозаполнения.

  66. Вспомните, как и когда можно использовать заполнение ячеек с помощью команд Excel.

  67. Как работает функция ДВССЫЛ ? Что она вычисляет? Приведите пример.

  68. Что такое автофильтра? Объясните его назначение.

  69. Расскажите и объясните алгоритм поиска минимума.

  70. Расскажите и объясните алгоритм поиска максимума.

  71. Расскажите и объясните алгоритм поиска среднего значения.

  72. Можно ли найти максимальный и минимальный элементы в одном цикле и одном условии. Обоснуйте свой ответ.

  73. Может ли максимальный элемент равняться минимальному элементу. Обоснуйте свой ответ.

  74. Объясните, что делает метод Clear.

  75. Что возвращает функция ЛЕВСИМВ. Зачем она нужна, приведите пример.

  76. Что возвращает функция ИНДЕКС. Зачем она нужна, приведите пример.

  77. Какие подзадачи решают при обработке информации?



Приложение
Таблица «Сессия»

Файл-заготовка содержит таблицу Excel c формулами (рис. 87).



^ Рис. 87. Первая часть таблицы «Сессия».

В ячейках AA18-AM317 находятся простые числа – оценки по предметам (от 2 до 5), расположенные случайным образом. В ячейках AB17-AM17 находятся краткие названия предметов («П1», …, «П12») с примечаниями – полными названиями. В ячейках AK11 и AT11 хранятся размеры стипендий для отличников и успевающих студентов соответственно.

Формулы в ячейках (скопировать в столбце до 317 строки):

^ AN18:=ОКРУГЛ(СРЗНАЧ(AB18:AM18),2)

AO18:=СЧЁТЕСЛИ(AB18:AM18,2)

AP18:=СЧЁТЕСЛИ(AB18:AM18,3)

AQ18:=СЧЁТЕСЛИ(AB18:AM18,4)

AR18:=СЧЁТЕСЛИ(AB18:AM18,5)

AS18:=ЕСЛИ(AO180,"двоечник",ЕСЛИ(AR18=12,"отличник",""))

AT18:=ЕСЛИ(AS18="двоечник","",ЕСЛИ(AS18="отличник",$AK$11, $AT$11))

Вторая часть таблицы содержит результаты обработки таблицы по студентам (рис. 88).




^ Рис. 88. Вторая часть таблицы «Сессия».

Формулы в ячейках:

AW17:=ЧИСЛСТОЛБ(AB18:AM18)*ЧСТРОК(AB18:AB317)

AW18:=СЧЁТЕСЛИ($AB$18:$AM$317,5)

AW19:=СЧЁТЕСЛИ($AB$18:$AM$317,4)

AW20:=СЧЁТЕСЛИ($AB$18:$AM$317,3)

AW21:=СЧЁТЕСЛИ($AB$18:$AM$317,2)

AW23:=ЧСТРОК(AM18:AM317)

AW25:=СЧЁТЕСЛИ($AS$18:$AS$317,"отличник")

AW26:=СЧЁТЕСЛИ($AS$18:$AS$317,"двоечник")

AW28:=AW25/$AW$23

AW29:=AW26/$AW$23

AW31:=СУММ(AT18:AT317)

AW33:=СУММЕСЛИ($AT$18:$AT$317,AT11)

AW34:=СУММЕСЛИ($AT$18:$AT$317,AK11)

Третья часть таблицы содержит результаты обработки таблицы по предметам (рис. 89).



^ Рис. 89. Третья часть таблицы «Сессия».

Формулы в ячейках:

AW38:=СУММ(AB$17:AB$318)/ЧСТРОК($AB$18:$AB$317) – скопировать в ячейки AW39:AW49

AY38:=МАКС(AW38:AW49)

^ AY40:="П"&ТЕКСТ(ПОИСКПОЗ(МАКС(AW38:AW49),AW38:AW49,0), "0")

Таблица «Температура»

Файл-заготовка содержит таблицу Excel c формулами (рис. 90).



Рис. 90. Первая часть таблицы «Температура»

В ячейках AA21, AA31, AA41, …, AA311 находятся года (числа) 1960, 1961, 1962, …, 1989. В ячейках AB21, …, AB320 периодически повторяются дни 1, 2, …, 10. В ячейках AC21-AC320 значения температуры (дробные числа) от 10 до 40. В ячейках AD21-AD320 отсортированные по возрастанию, а в AE21-AE320 по убыванию значения температуры.

Формулы в ячейках:

^ AH20:=ЧСТРОК(AC21:AC320)

AH21:=МАКС(AC21:AC320)

AH22:=МИН(AC21:AC320)

AH23:=ОКРУГЛ(СРЗНАЧ(AC21:AC320),2)

AH27:=ОКРУГЛ(СРЗНАЧ(ЕСЛИ($AB$21:$AB$320=AG27,$AC$21: $AC$320)),2) – скопировать в столбец AH28-AH36

^ AK21:=НАИБОЛЬШИЙ($AC$21:$AC$320,AJ21) – скопировать в AK22-AK25

AK28:=НАИМЕНЬШИЙ($AC$21:$AC$320,AJ28) – скопировать в AK29-AK32

Результаты обработки значений температуры показаны на рис. 91.



Рис. 91. Вторая часть таблицы «Температура».

Формулы в ячейках:

AH39:=СЧЁТЕСЛИ($AC$21:$AC$320,AG39) – скопировать в ячейки AH40-AH44

AH47:=AH39

AH48:=AH40-AH39

AH49:=AH41-AH40

AH50:=AH42-AH41

AH51:=AH43-AH42

AH52:=AH44

AM54:=СРЗНАЧ(AM23:AM52)

AM55:=МАКС(AM24:AM52)

AM56:=МИН(AM23:AM52)

AO54:=СРЗНАЧ(AO23:AO52)

AO55:=МАКС(AO24:AO52)

AO56:=МИН(AO23:AO52)

В столбце перед средним, максимальным и минимальным значениям по дням находятся данные – значения температуры в этот день в разные года. Для их извлечения используется формула:

AM23:=ДВССЫЛ(AN23)

Эта формула скопирована в ячейки AM24-AM52. Данные для этой формулы берутся из соседнего столбца (AN23-AN52), в который они заносятся вручную. Там находятся названия ячеек ac21, ac31, …, ac311 в виде текста.

Для других дней формулы идентичны.

^ Таблица «Автомашины»

Вид таблицы показан на рис. 92, 93, 94.




Рис. 92. Первая часть таблицы «Автомашины».




Рис. 93. Вторая часть таблицы «Автомашины».




Рис. 94. Третья часть таблицы «Автомашины».

Примечания в ячейках:

AC45: Воспользуйтесь формулой массива {=сумм(если…)} для подсчета объемов продаж

^ AM51: Используйте функцию НАИБОЛЬШИЙ( )

AN51: Используйте функции ПОИСКПОЗ( ) и ИНДЕКС(диапазон; индекс), вторая функция возвращает значение ячейки из указанного диапазона ячеек, по индексу (находится с помощью первой функции).

AT45: Для выделения "Жигулей" воспользуйтесь функцией ЛЕВСИМВ(). Эта функция возвращает левый символ строки, содержащийся в ячейке по указанному адресу (аналогично функции Left(S$,1)). Применяйте формулы массива. Вычисление процента ведите относительно ячейки AN40.

AU45: Введите формулу подсчета числа российских машин проданных за 1-ое полугодие.

Формула в ячейке AD57:=СУММ(AC45:AC52).
^ Cписок использованной литературы

  1. Информатика. Базовый курс / Симонович С. В. и др. – СПб: Питер, 2000. – 640 с.

  2. Якубайтис Э. А. Информационные сети и системы. Справочная книга. – М.: Финансы и статистика, 1996. – 368 с.

  3. Додж М., Стинсон К. Эффективная работа с Microsoft Excel 2000. Пер. с англ. – СПб: Питер, 2000. – 1056 с.

  4. Язык компьютера. / Под ред. В. М. Курочкина. Пер. с англ. – М.: Мир, 1989. – 240 с.

  5. Петров А. В. и др. Вычислительная техника и программирование: Курсовая работа / Петров А. В., Титов М. А., Шкатов П. Н.; Под ред. А. В. Петрова. – М.: Высш. шк., 1992. – 192 с.



Содержание



УДК 681.03.06 5

Введение 6

1. Общие сведения о табличных процессорах 8

1.1. Появление табличных процессоров 8

1.2. Характеристики табличного процессора 10

^ 2. Основные навыки работы с Microsoft Excel 14

2.1. Основные понятия табличного процессора 14

2.1.1. Именованный стиль 14

2.1.2. Нумерованный стиль 15

2.1.3. Объекты таблицы 15

2.2. Вид табличного процессора Excel 16

2.3. Перемещение по таблице и выделение ячеек 16

2.4. Ввод данных в ячейки 19

2.4.1. Ввод чисел 20

2.4.2. Ввод текста 21

2.4.3. Ввод дат и времени суток 21

2.5. Форматирование ячеек 22

2.6. Операции копирования, удаления, перемещения, 30

очистки и заполнения ячеек 30

2.7. Операции изменения размеров строк и столбцов 35

2.8. Операции с файлами 37

2.9. Самоконтроль 39

2.9.1. Контрольные вопросы к главе 1 и 2 40

2.9.2. Упражнения на самостоятельную работу 41

^ 3. Вычисления в Microsoft Excel 42

3.1. Синтаксис формулы 42

3.1.1. Операторы в формулах 43

3.1.2. Приоритет операторов 44

3.2. Ссылки на ячейку 45

3.2.1. Относительные и абсолютные ссылки 46

3.3. Использование функций для вычисления значений 49

3.3.1. Использование панели формул 50

3.3.2. Ввод формулы с функцией 51

3.3.3. Мастер функций 52

3.4. Группы функций 55

3.5. Самоконтроль 57

3.5.1. Контрольные вопросы 58

3.5.2. Упражнения на самостоятельную работу 59

^ 4. Работа с листами и окнами 60

4.1. Выбор листов в книге 61

4.2. Изменение количества отображаемых ярлычков листов 61

4.3. Контекстно-зависимое меню для ярлычков листов 62

4.4. Управление видимостью листов 64

4.5. Несколько окон для одного рабочего листа 64

4.6. Смена, сокрытие, свертывание окон 66

4.7. Изменение масштаба изображения 66

4.8. Самоконтроль 66

4.8.1. Контрольные вопросы 67

4.8.2. Упражнения на самостоятельную работу 68

^ 5. Создание макросов 69

5.1. Запись макроса 70

5.2. Выполнение макроса 71

5.3. Назначение области графического объекта 72

для запуска макроса 72

5.4. Назначение кнопки панели инструментов 72

для запуска макроса 72

5.5. Удаление макроса 74

5.6. Самоконтроль 75

5.6.1. Контрольные вопросы 75

5.6.2. Упражнения на самостоятельную работу 76

^ 6. Построение диаграмм 77

6.1. Шаг 1. Выбор типа диаграммы 77

6.2. Шаг 2. Источник данных диаграммы 86

6.3. Шаг 3. Параметры диаграммы 88

6.4. Шаг 4. Размещение диаграммы 88

6.5. Самоконтроль 89

6.5.1. Контрольные вопросы 89

6.5.2. Упражнения на самостоятельную работу 90

^ 7. Введение в Visual Basic for Application 91

7.1. Изучение свойств интерфейсного объекта UserForm 92

7.2. Окно проекта 95

7.3. Интерфейсные объекты 96

7.3.1. Надпись 97

7.3.2. Поле 98

7.3.3. Кнопка 100

7.3.4. Выключатель 101

7.3.5. Флажок 101

7.3.6. Переключатель 102

7.3.7. Список 102

7.3.8. Поле со списком 103

7.3.9. Полоса прокрутки 104

7.3.10. Счетчик 104

7.3.11. Рамка 104

7.3.12. Рисунок 105

7.4. Самоконтроль 105

7.4.1. Контрольные вопросы 106

7.4.2. Упражнения на самостоятельную работу 109

^ 8. Задачи обработки информации 110

8.1. Постановка задачи 111

8.2. Решение задачи 112

8.2.1. Работа с примечаниями 112

8.2.2. Определение среднего балла 113

8.2.3. Определение количества оценок каждого вида 115

8.2.4. Определение категории студента 116

8.2.5. Определение стипендии студента 118

8.2.6. Определение стипендиального фонда 119

8.2.7. Вычисление процентных отношений 119

8.2.8. Вычисление среднего балла 120

по предметам и определение максимального из них 120

8.2.9. Выделение категории студентов 122

с помощью условного форматирования 122

8.2.10. Построение диаграммы 124

8.2.11. Создание программного кода 125

8.3. Применение полученных знаний 136

для решения однотипных задач 136

8.3.1. Задача обработки информации 136

об измерениях температуры 136

8.3.2. Некоторые особенности решения 137

задачи обработки температур 137

8.3.3. Нахождение максимального, 137

минимального и среднего значения 137

8.3.4. Упорядочивание данных 138

8.3.5. Расчет средних значений для каждого дня 139

8.3.6. Расчет первых пяти наибольших 141

и последних пяти наименьших значений 141

8.3.7. Расчет числа дней, в которых 141

температура была в одном из диапазонов 141

8.3.8. Составление таблицы температур 142

8.3.9. Условное форматирование и автофильтр 143

8.3.10. Составление программы 143

8.4. Задача на самостоятельное решение 145

8.5. Самоконтроль 146

8.5.1. Контрольные вопросы 146

Приложение 149

Cписок использованной литературы 156


Содержание …………………………………………………………………………………...148




almati-astana-baku-grodno-kiev-kishenev-kolambiya-lyudenshajd-minsk-nevinnomissk-tashkent-harkov-elista-2010.html
almati-oblisi-arasaj-audani-kenen-zrbaev-atindai-orta-mektep-kmm-ailshin-tl-pnnen.html
almati-oblisi-kksu-audani-balpi-bi-auili-zhldiz-bbek-zhaj-balabashasi-k-m-k-balapan-ksh-tobi.html
almati-oblisini-arzhi-basarmasi-byudzhettk-badarlama-kmshsn-kodi-zhne-ataui-2016-2018-zhildara-arnalan-byudzhettk-badarlamani-kodi-zhne-ataui.html
almati-otd-bojinsha-18-10-2013zh-bos-orindar-azatelekom-a-filiali-almati-otd-na-azhet-bas-apparat-bojinsha-bos-orindar.html
almaz-mineral-chast-2.html
  • tasks.bystrickaya.ru/1-stupen-mou-andrinskaya-srednyaya-obsheobrazovatelnaya-shkola-publichnij-doklad-mou-andrinskaya-srednyaya-obsheobrazovatelnaya.html
  • lecture.bystrickaya.ru/61-rizhov-n-m-semenov-m-yu-modelirovanie-neizotermicheskih-processov-ionnoj-nitrocementacii.html
  • otsenki.bystrickaya.ru/shemi-issledovaniya-vliyaniya-gazovidelenij-iz-polimernih-materialov-na-organizm-v-hronicheskom-eksperimente.html
  • writing.bystrickaya.ru/boris-kagarlickij-rokirovochka-boris-grizlov-monitoring-smi-8-10-iyulya-2006-g.html
  • studies.bystrickaya.ru/bankovskaya-sistema-rf-chast-22.html
  • shpargalka.bystrickaya.ru/upravlenie-obrazovaniya-administacii-starooskolskogo-gorodskogo-okruga.html
  • studies.bystrickaya.ru/gavrila-derzhavin-i-ego-shkola-v-russkoj-literature.html
  • school.bystrickaya.ru/bileti-po-mezhkulturnoj-kommunikacii-chast-22.html
  • institute.bystrickaya.ru/glava-17-elena-chudinova-mechet-parizhskoj-bogomateri.html
  • ekzamen.bystrickaya.ru/rossiya-segodnya-ekskursiya-po-moskve-i-sankt-peterburgu-stranica-3.html
  • uchenik.bystrickaya.ru/logisticheskie-sistemi-v-upravlenii-predpriyatiem.html
  • knowledge.bystrickaya.ru/novie-tehnologii-kak-vospitatelnij-resurs-informacionnij-byulleten-izbiratelnoj-komissii-rostovskoj-oblasti.html
  • esse.bystrickaya.ru/realizaciya-gorodskih-celevih-programm-po-razvitiyu-vnutrennego-i-vezdnogo-turizma-na-territorii-g-kungura.html
  • credit.bystrickaya.ru/opit-istoricheskogo-analiza-fenomena-asimmetrichnogo-konflikta-v-mezhdunarodnih-otnosheniyah-vtoraya-polovina-hh-nachalo-xxi-v.html
  • znanie.bystrickaya.ru/59-normativistskaya-teoriya-prava-voprosi-i-otveti.html
  • ekzamen.bystrickaya.ru/rossijskoj-federacii-rukovodstvo-po-deloproizvodstvu-v-voennih-sudah-stranica-3.html
  • college.bystrickaya.ru/20072010-g-s-3-tema-stroitelstvo-stroitelen-kontrol.html
  • textbook.bystrickaya.ru/istoriya-eto-ne-to-chto-bilo-eto-to-chto-mozhet-bit-potomu-chto-bilo-odnazhdi-stranica-9.html
  • thesis.bystrickaya.ru/programma-elektivnogo-kursa-dlya-9-klassov-avtor-kononenko-g-v.html
  • znanie.bystrickaya.ru/akcionernoe-obshestvo-manotom.html
  • thescience.bystrickaya.ru/institut-problem-himicheskoj-fiziki-ran-tezisi-lekcij-i-stendovih-dokladov.html
  • pisat.bystrickaya.ru/strah-nenavistnoj-rozni-mira-sego-stranica-2.html
  • grade.bystrickaya.ru/morfometricheskie-pokazateli-samok-polevok-otlovlennih-problemi-regionovedeniya-geograficheskie-etapi-izucheniya-i.html
  • crib.bystrickaya.ru/gosudarstvennij-komitet-soveta-ministrov-sssr-po-voprosam-truda-i-zarabotnoj-plati-stranica-11.html
  • kontrolnaya.bystrickaya.ru/razmishleniya-o-rossijskom-pravyashem-sloe.html
  • tetrad.bystrickaya.ru/vivod-po-razdelu-tamara-pavlovna-17.html
  • tests.bystrickaya.ru/metodicheskie-rekomendacii-k-izucheniyu-disciplini-uchet-analiz-i-audit-vneshneekonomicheskoj-deyatelnosti-dlya-studentov-specialnosti-080109-buhgalterskij-uchet-analiz-i-audit-zaochnoj-formi-obucheniya-bijsk.html
  • nauka.bystrickaya.ru/v-n-morozovu.html
  • school.bystrickaya.ru/izmerenie-neelektricheskih-velichin.html
  • universitet.bystrickaya.ru/tema-6-specifika-hudozhestvennogo-tvorchestva-4-chasa-metodicheskie-ukazaniya-dlya-studentov-tematicheskij-plan.html
  • books.bystrickaya.ru/d-drmen-e-bauirmal-dris-tasimaldanan-szd-tap-a-ta-bis.html
  • institute.bystrickaya.ru/evropejskaya-politika-sosedstva-i-strani-sng-almanah-centra-obshestvennih-ekspertiz-vipusk-aprel-2008-g-almanah.html
  • letter.bystrickaya.ru/mne-dostavlyaet-bolshoe-udovolstvie.html
  • notebook.bystrickaya.ru/kandidoz-kozhi-a-n-rodionov-gribkovie-zabolevaniya-kozhi.html
  • shkola.bystrickaya.ru/programmi-predlagayutsya-na-bumazhnom-i-elektronnom-nositelyah-perechen-stranica-4.html
  • © bystrickaya.ru
    Мобильный рефератник - для мобильных людей.